User web application is experiencing issues
Resolved
Apr 22, 2026 at 6:56pm UTC
Auth0 seems to have resolved the issue.
We keep on monitoring the situation and would update if anything changes.
Affected services
Updated
Apr 22, 2026 at 6:49pm UTC
We have identified the root cause of the problem. Our sub-processor Auth0 which is used for Authentication of users is experiencing issues which impacts our web application.
They have not yet acknowledged the issue, but we expect them to do so very soon.
Important: Applications of candidates are not impacted.
Affected services
Created
Apr 22, 2026 at 6:45pm UTC
Some pages of our web application are currently not working. Applications do not seem to be impacted.
We are investigating the issue and will report back.
Affected services