Back to overview
Degraded
Dropdowns not clickable
Feb 18, 2026 at 5:53pm UTC
Affected services
PastaHR
Resolved
Feb 18, 2026 at 6:24pm UTC
We have pushed a fix and the issue is resolved.
We apologise for any inconvenience caused by this issue. We will thoroughly debrief regarding this issue in the team and do an internal post mortem.
If you have any questions, please reach out to us at any time!
Affected services
Created
Feb 18, 2026 at 5:53pm UTC
We have found an issue that causes dropdowns in our product to not be clickable anymore. This impacts the web application as well as the online application form.
We are already working on a fix and will keep you updated here.
Affected services