Back to overview
Degraded

Performance degradation

Apr 29 at 07:50pm CEST
Affected services
PastaHR

Resolved
Apr 29 at 08:21pm CEST

We have resolved the issue and are closely monitoring the system.

We apologise for any inconvenience cause. If you have any questions, do not hesitate to reach out to us at any time.

Created
Apr 29 at 07:50pm CEST

We noticed slower network responses of our system and are currently investigating the issue.

We apologise for any inconvenience caused and will keep you updated on this thread.