Back to overview
Degraded

Login emails delayed to to problem at Brevo.com

Oct 20 at 05:39pm CEST
Affected services
PastaHR

Resolved
Oct 20 at 06:40pm CEST

Brevo has resolved the issue! Everything works normally again.

Created
Oct 20 at 05:39pm CEST

Our email provider is currently facing problems. Therefore, emails are only sent out with a delay.

Please reach out to support@pastahr.com if you need to log in and don't receive an email.

Find more information here: https://status.brevo.com/